API Versions

Each plugin must specify the target API version in the format major.minor. Marta performs the following checks when the plugin is loaded:

  • When the Marta API major version is not the same (the required version is higher or lower) as the required version, the plugin is not loaded, and the warning alert is shown.
  • When the Marta API minor version is lower than the required version, the plugin is not loaded, and the warning alert is shown.

The table below describes the mapping between Marta versions and the corresponding API versions:

Marta version API version
Marta 0.5.3 6.0
Marta 0.5.2 6.0
Marta 0.5.1 6.0
Marta 0.5 5.0
Marta 0.4.6 4.6
Marta 0.4.5 4.5
Marta 0.4.4 4.4
Marta 0.4.3 4.3
Marta 0.4.2 4.2
Marta 0.4.1 4.1
Marta 0.4 4.0
Marta 0.3 3.0
Marta 0.2.1 2.0
Marta 0.2 2.0